ASP.NET Web Site Administration Tool

Nov 30, 2007 at 12:23 AM
Hi,
for some reason Web Site Administration Tool is not connecting to the database

connection string :
<add name="ConStr" connectionString="Server=localhost;Port=3306;Database=mysqlproviders;Uid=root;Pwd=admin;" providerName="System.Data.SqlClient"/>
Coordinator
Nov 30, 2007 at 9:04 PM
Hi,
unfortunatly i have the same problem. I didn't use this tool to administrate my web site.
I have cheked on the net and the problem seems to occur with other mysql custom providers but i didn't find yet a solution.

Did you tried to define the provider in the machine.config and register the assembly in the GAC?
Nov 30, 2007 at 11:04 PM
Hi,
I neither configured machine.config nor GAC , i think we can work it out to solve this issue, most of developers use WSAT before publishing .

Thanks,
Amr
Coordinator
Dec 1, 2007 at 8:39 AM
ok,

i've open an issue for that point.
Jun 3, 2008 at 9:14 PM
Hello, as they are, I have a problem. I get the error in WSAT: Reference to object not established as an object instance. I can help. register the assembly in the GAC

<

 

connectionStrings>

 

<

 

add name="SimpleProviderconnectionstring" connectionString="Server=localhost;Port=3306;Database=mysqlproviders;Uid=root;Pwd=root;" providerName="System.Data.SqlClient"/>

 

</

 

connectionStrings>

 

<

 

system.web>

 

<

 

roleManager defaultProvider="MySqlRoleProvider" enabled="true" cacheRolesInCookie="true" cookieName=".ASPROLES" cookieTimeout="30" cookiePath="/" cookieRequireSSL="false" cookieSlidingExpiration="true" cookieProtection="All">

 

<

 

providers>

 

<

 

clear/>

 

<

 

add name="MySqlRoleProvider" connectionStringName="SimpleProviderconnectionstring" applicationName="UsuMysqlWeb" type="CodeFx.MySqlProviders.MySqlRoleProvider"/>

 

</

 

providers>

 

</

 

roleManager>

 

<

 

membership defaultProvider="MySqlMembershipProvider" userIsOnlineTimeWindow="15">

 

<

 

providers>

 

<

 

clear/>

 

<

 

add connectionStringName="SimpleProviderconnectionstring" applicationName="UsuMysqlWeb" enablePasswordRetrieval="true" enablePasswordReset="true" requiresQuestionAndAnswer="true" requiresUniqueEmail="true" passwordFormat="Clear" name="MySqlMembershipProvider" type="CodeFx.MySqlProviders.MySqlMembershipProvider"/>

 

</

 

providers>

 

</

 

membership>

 

<

 

webParts>

 

<

 

personalization defaultProvider="MySqlPersonalizationProvider">

 

<

 

providers>

 

<

 

add name="MySqlPersonalizationProvider" type="CodeFx.MySqlProviders.MySqlPersonalizationProvider" connectionStringName="SimpleProviderconnectionstring" applicationName="UsuMysqlWeb"/>

 

</

 

providers>

 

<

 

authorization>

 

<

 

allow users="*" verbs="enterSharedScope"/>

 

</

 

authorization>

 

</

 

personalization>

 

</

 

webParts>

 

<

 

anonymousIdentification enabled="true"/>

 

<

 

profile defaultProvider="MySqlProfileProvider">

 

<

 

providers>

 

<

 

clear/>

 

<

 

add name="MySqlProfileProvider" type="CodeFx.MySqlProviders.MySqlProfileProvider" applicationName="UsuMysqlWeb" connectionStringName="SimpleProviderconnectionstring"/>

 

</

 

providers>

 

<

 

properties>

 

<

 

add name="SomeCustomProperty" type="string" allowAnonymous="true"/>

 

</

 

properties>

 

</

 

profile>